AuthorTopic: -NowvaB's Animation Thread-  (Read 6805 times)

Offline HarveyDentMustDie

  • 0010
  • *
  • Posts: 469
  • Karma: +0/-0
  • I dream too much.
    • View Profile
    • Deviant Art

Re: -NowvaB's Animation Thread-

Reply #10 on: December 31, 2014, 03:28:14 pm
Here's the edit of your power punch. Because of a lot of frames during the punch it looks very slow and powerless. Best reference and learning material for this kind of animations are PixelPiledriver posts here on this forum http://wayofthepixel.net/index.php?action=profile;area=showposts;u=9280

Offline NowvaB

  • 0001
  • *
  • Posts: 93
  • Karma: +0/-0
    • View Profile
    • Tumblr

Re: -NowvaB's Animation Thread-

Reply #11 on: January 01, 2015, 01:51:39 pm
Fixing the corner collisions brought out the worst in me, but I finally got it somewhere acceptable :blind:
(I almost scrapped v&h speed and wrote my own from scratch!)

Thanks for all the feed back everyone.

The blur I was referring to was on the left and right movement. It looks like there is too images on the screen, one of his current location and the other a blurred version a pixel further away.
This might be natural but I haven't played a game with a fixed camera in a while.

grue: Not intentional at all! It was made to go to frame 4 as soon as there is downward movement so the 3rd frame gets cut off. I did that because for some reason GameMaker refuses to check...
if(image_index == value). So I cant let the animation follow through and then stop.

HarveyDentMustDie: Thanks, Harvey. I think mine looked weird because I simulated his movement through a low, unmeasured frame rate, I think when I add it into the 'game' it will look a lot more pleasing to the eye.

and gifs for Rosier / gil:    I think it looks alright... kinda hard to tell. I think all it needs is a different move speed, but I do have other run sprites in mind.


*added a crouch and a 'camera toggle'


and lastly before I overload the server with data :crazy:. GameMaker is having a problem with the sprites. when not moving there are stretching errors and when moving sprite deforms... help me...

Offline Probo

  • 0010
  • *
  • Posts: 317
  • Karma: +1/-0
    • View Profile

Re: -NowvaB's Animation Thread-

Reply #12 on: January 01, 2015, 03:18:00 pm
is the sprite moving between pixels? like are its coordinates going to a decimal place? that can deform the sprite like that. try adding something like

x = round(x);
y = round(y);

at the end of the step event to see if that fixes it.

if thats the problem though, the final fix should probably be rounding the speed before its applied to the coordinates rather than rounding the coordinates themselves.

and that blur sprite thing sounds like plain old lcd ghosting
« Last Edit: January 01, 2015, 03:22:13 pm by Probo »

Offline NowvaB

  • 0001
  • *
  • Posts: 93
  • Karma: +0/-0
    • View Profile
    • Tumblr

Re: -NowvaB's Animation Thread-

Reply #13 on: January 02, 2015, 11:04:07 am
 :y: :y: :y: worked beautifully! thanks!

I added the lines into an End Step event and the sprites fixed. It also fixed a nit-picky platforming issue.

Offline Gil

  • 0100
  • ***
  • Posts: 1543
  • Karma: +1/-0
  • Too square to be hip
    • http://pixeljoint.com/p/475.htm
    • View Profile
    • My Portfolio

Re: -NowvaB's Animation Thread-

Reply #14 on: January 02, 2015, 01:04:59 pm
The run animation is a bit sluggish, but otherwise looks fine. The optical illusion carries over just a bit, but I don't mind it :)